Elevated email service send error rate
Incident Report for TeamUp
Resolved
Between approximately 08:00 and 12:00 UTC our primary email sending service was down. During this time, our backup email sending service had a high error rate. A large percentage of emails sent during this time were not delivered. Emails sent between approximately 12:00 and 14:10 UTC were delayed. Starting at 14:10, normal sending service resumed.

We identified the causes of these failures and have implemented additional measures to prevent this going forward.
Posted Feb 26, 2019 - 15:41 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 26, 2019 - 14:29 UTC
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Feb 26, 2019 - 14:28 UTC
Investigating
We're seeing increased errors sending emails to all TeamUp users. We are investigating and will update as we know more.
Posted Feb 26, 2019 - 13:51 UTC
This incident affected: Notifications (Email Notifications).