Increased load times
Incident Report for TeamUp
Resolved
All systems are now operating normally.
Posted Oct 22, 2018 - 06:37 UTC
Monitoring
We have identified and issue that was causing slow page loads for a subset of users. We have made a change to resolve the issue. We are monitoring the situation.
Posted Oct 22, 2018 - 06:31 UTC
This incident affected: Website.